const regex = /^([1-9]|[1-5][0-9]|60(\.0{1,2})?$)(\.[0-9]{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]|[1-5][0-9]|60(\\.0{1,2})?$)(\\.[0-9]{1,2})?$', 'gm')
const str = `0
0.01
1
1.0
9
10
19
20
21
21.23
21.234
29
30
31
39
40
41
49
50
53
59
60
60.00
60.01
61`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}