import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]|[1-5][0-9]|60(\\.0{1,2})?$)(\\.[0-9]{1,2})?$";
final String string = "0\n"
+ "0.01\n"
+ "1\n"
+ "1.0\n"
+ "9\n"
+ "10\n"
+ "19\n"
+ "20\n"
+ "21\n"
+ "21.23\n"
+ "21.234\n"
+ "29\n"
+ "30\n"
+ "31\n"
+ "39\n"
+ "40\n"
+ "41\n"
+ "49\n"
+ "50\n"
+ "53\n"
+ "59\n"
+ "60\n"
+ "60.00\n"
+ "60.01\n"
+ "61";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}