#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:1,99[4-9]|2,00[0-6])$"
Local $sString = "1,993" & @CRLF & _
"1,994" & @CRLF & _
"1,995" & @CRLF & _
"1,996" & @CRLF & _
"1,997" & @CRLF & _
"1,998" & @CRLF & _
"1,999" & @CRLF & _
"2,000" & @CRLF & _
"2,001" & @CRLF & _
"2,002" & @CRLF & _
"2,003" & @CRLF & _
"2,004" & @CRLF & _
"2,005" & @CRLF & _
"2,006" & @CRLF & _
"2,007"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")