// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:1,99[4-9]|2,00[0-6])$").unwrap();
let string = "1,993
1,994
1,995
1,996
1,997
1,998
1,999
2,000
2,001
2,002
2,003
2,004
2,005
2,006
2,007";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}