# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:1,99[4-9]|2,00[0-6])$"
test_str = ("1,993\n"
"1,994\n"
"1,995\n"
"1,996\n"
"1,997\n"
"1,998\n"
"1,999\n"
"2,000\n"
"2,001\n"
"2,002\n"
"2,003\n"
"2,004\n"
"2,005\n"
"2,006\n"
"2,007")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.