package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:1,99[4-9]|2,00[0-6])$`)
var str = `1,993
1,994
1,995
1,996
1,997
1,998
1,999
2,000
2,001
2,002
2,003
2,004
2,005
2,006
2,007`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}