// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^"([^"]*)""([^"]*)""([^"]*)""#).unwrap();
let string = "\"C:\\users\\downloads\\1.txt\"\"1460577050\"\"63f9fa2d3e3b5bc31cc3663e4cc7167f1d763c6fa880943e5995fda8a34bd030\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}