#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9\-\.`]+\s{0,1}[a-z0-9\-\.`]+$"
Local $sString = "st-abcd" & @CRLF & _
" sta bcd" & @CRLF & _
"st abc" & @CRLF & _
"ghij" & @CRLF & _
"abcd hij.klmn`opqr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")