package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-z0-9\-\.`]+\s{0,1}[a-z0-9\-\.`]+$`)
var str = `st-abcd
sta bcd
st abc
ghij
abcd hij.klmn\`opqr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}