import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9\\-\\.`]+\\s{0,1}[a-z0-9\\-\\.`]+$";
final String string = "st-abcd\n"
+ " sta bcd\n"
+ "st abc\n"
+ "ghij\n"
+ "abcd hij.klmn`opqr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}