re = /^[a-z0-9\-\.`]+\s{0,1}[a-z0-9\-\.`]+$/mi
str = 'st-abcd
sta bcd
st abc
ghij
abcd hij.klmn`opqr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end