package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`KEY.*?(\d+)`)
var str = `test 74488 hdhd2 76awd45w34 4keydfs332zd8 788 KEY gjj123566 121 545 45 487 87 jcrs . . bla `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}