// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"KEY.*?(\d+)").unwrap();
let string = "test 74488 hdhd2 76awd45w34 4keydfs332zd8 788 KEY gjj123566 121 545 45 487 87 jcrs . . bla ";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}