import Foundation
let pattern = #"KEY.*?(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"test 74488 hdhd2 76awd45w34 4keydfs332zd8 788 KEY gjj123566 121 545 45 487 87 jcrs . . bla "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}