re = /KEY.*?(\d+)/
str = 'test 74488 hdhd2 76awd45w34 4keydfs332zd8 788 KEY gjj123566 121 545 45 487 87 jcrs . . bla '
# Print the match result
str.match(re) do |match|
puts match.to_s
end