#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((?:0|0033|\+33)[1-9])((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})$"
Local $sString = "0604038164"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")