using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:0|0033|\+33)[1-9])((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})$";
string input = @"0604038164";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}