$re = '/^((?:0|0033|\+33)[1-9])((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})$/';
$str = '0604038164';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);