re = /^((?:0|0033|\+33)[1-9])((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})((?:[-_. ]?)[0-9]{2})$/
str = '0604038164'
# Print the match result
str.match(re) do |match|
puts match.to_s
end