using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=“conditionDescription”:“).*(?=.”,“conditionType”)";
string input = @"{“conditionCode”:“X51”,“conditionDescription”:“We may be able to assess this.”,“conditionType”:“ADMIN”},
{“conditionCode”:“X50”,“conditionDescription”:“Despite research we have not succeeded.”,“conditionType”:“ADMIN”}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}