import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=“conditionDescription”:“).*(?=.”,“conditionType”)";
final String string = "{“conditionCode”:“X51”,“conditionDescription”:“We may be able to assess this.”,“conditionType”:“ADMIN”},\n"
+ "{“conditionCode”:“X50”,“conditionDescription”:“Despite research we have not succeeded.”,“conditionType”:“ADMIN”}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}