$re = '/(?<=“conditionDescription”:“).*(?=.”,“conditionType”)/m';
$str = '{“conditionCode”:“X51”,“conditionDescription”:“We may be able to assess this.”,“conditionType”:“ADMIN”},
{“conditionCode”:“X50”,“conditionDescription”:“Despite research we have not succeeded.”,“conditionType”:“ADMIN”}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);