re = /(?<=“conditionDescription”:“).*(?=.”,“conditionType”)/m
str = '{“conditionCode”:“X51”,“conditionDescription”:“We may be able to assess this.”,“conditionType”:“ADMIN”},
{“conditionCode”:“X50”,“conditionDescription”:“Despite research we have not succeeded.”,“conditionType”:“ADMIN”}]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end