using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" \(?\b[A-Z.]{2,3}\b.+";
string input = @"Spain (ES)
Netherlands (NL .
United States (USA.
Russia RU)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}