re = / \(?\b[A-Z.]{2,3}\b.+/m
str = 'Spain (ES)
Netherlands (NL .
United States (USA.
Russia RU)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end