package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) \(?\b[A-Z.]{2,3}\b.+`)
var str = `Spain (ES)
Netherlands (NL .
United States (USA.
Russia RU)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}