package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w*?\d\w*\b`)
var str = `This is 4test
of multiple lines. This is 2nd line
This is 3rd line 12345
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}