re = /\b\w*?\d\w*\b/
str = 'This is 4test
of multiple lines. This is 2nd line
This is 3rd line 12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end