const regex = /\b\w*?\d\w*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\w*?\\d\\w*\\b', 'g')
const str = `This is 4test
of multiple lines. This is 2nd line
This is 3rd line 12345
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}