using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S*)\((?:[^)]|//[^\r\n]*\)|/\*(?:(?!\*/).)*\*/)*ref\s*SqlConnection";
string input = @"public static bool InsertNotes(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName)
{ //Stuff here
}
public static bool InsertNote1(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{ //Stuff here
}
public static bool InsertNote2(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
/*string Company, string NoteCategory, ref OracleConnection Connection)*/
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{ //Stuff here
}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}