re = /(\S*)\((?:[^)]|\/\/[^\r\n]*\)|\/\*(?:(?!\*\/).)*\*\/)*ref\s*SqlConnection/
str = 'public static bool InsertNotes(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName)
{ //Stuff here
}
public static bool InsertNote1(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{ //Stuff here
}
public static bool InsertNote2(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
/*string Company, string NoteCategory, ref OracleConnection Connection)*/
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{ //Stuff here
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end