use strict;
my $str = 'public static bool InsertNotes(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName)
{ //Stuff here
}
public static bool InsertNote1(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{ //Stuff here
}
public static bool InsertNote2(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
/*string Company, string NoteCategory, ref OracleConnection Connection)*/
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{ //Stuff here
}';
my $regex = qr~(\S*)\((?:[^)]|//[^\r\n]*\)|/\*(?:(?!\*/).)*\*/)*ref\s*SqlConnection~sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}