# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\S*)\((?:[^)]|//[^\r\n]*\)|/\*(?:(?!\*/).)*\*/)*ref\s*SqlConnection"
test_str = ("public static bool InsertNotes(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
" //string Company, string NoteCategory, ref OracleConnection Connection)\n"
" string Company, string NoteCategory, string DocumentName)\n"
" { //Stuff here\n"
"}\n\n"
"public static bool InsertNote1(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
" //string Company, string NoteCategory, ref OracleConnection Connection)\n"
" string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)\n"
" { //Stuff here\n"
"}\n\n"
"public static bool InsertNote2(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,\n"
" string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,\n"
" string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,\n"
" /*string Company, string NoteCategory, ref OracleConnection Connection)*/\n"
" string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)\n"
" { //Stuff here\n"
"}")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.