#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^----\n([\s\S]*)\n----$"
Local $sString = "----" & @CRLF & _
"line-1" & @CRLF & _
"line-2" & @CRLF & _
"line-3" & @CRLF & _
"line-4" & @CRLF & _
"----"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")