$re = '/^----\n([\s\S]*)\n----$/';
$str = '----
line-1
line-2
line-3
line-4
----';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);