const regex = /^----\n([\s\S]*)\n----$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^----\\n([\\s\\S]*)\\n----$', '')
const str = `----
line-1
line-2
line-3
line-4
----`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}