package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^----\n([\s\S]*)\n----$`)
var str = `----
line-1
line-2
line-3
line-4
----`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}