using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w+\s]+)\s([\d]+)(%|\w+)\s(\w+)\s(\w+)\sx\s(\d)\/(\d+)";
string input = @"calamine lotion 1% aaa od x 2/52";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}