re = /([\w+\s]+)\s([\d]+)(%|\w+)\s(\w+)\s(\w+)\sx\s(\d)\/(\d+)/
str = 'calamine lotion 1% aaa od x 2/52'
# Print the match result
str.match(re) do |match|
puts match.to_s
end