const regex = /([\w+\s]+)\s([\d]+)(%|\w+)\s(\w+)\s(\w+)\sx\s(\d)\/(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w+\\s]+)\\s([\\d]+)(%|\\w+)\\s(\\w+)\\s(\\w+)\\sx\\s(\\d)\\\/(\\d+)', '')
const str = `calamine lotion 1% aaa od x 2/52`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}