package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w+\s]+)\s([\d]+)(%|\w+)\s(\w+)\s(\w+)\sx\s(\d)\/(\d+)`)
var str = `calamine lotion 1% aaa od x 2/52`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}