package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?: {4}|\t)(?P<name>\*{0,2}\w+):(?P<desc>(?:\s|.*)*)`)
var str = ` bool: True if successful, False otherwise.
The return type is optional and may be specified at the beginning of
the \`\`Returns\`\` section followed by a colon.
The \`\`Returns\`\` section may span multiple lines and paragraphs.
Following lines should be indented to match the first line.
The \`\`Returns\`\` section supports any reStructuredText formatting,
including literal blocks::
{
'param1': param1,
'param2': param2
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}