import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?: {4}|\\t)(?P<name>\\*{0,2}\\w+):(?P<desc>(?:\\s|.*)*)";
final String string = " bool: True if successful, False otherwise.\n\n"
+ " The return type is optional and may be specified at the beginning of\n"
+ " the ``Returns`` section followed by a colon.\n\n"
+ " The ``Returns`` section may span multiple lines and paragraphs.\n"
+ " Following lines should be indented to match the first line.\n\n"
+ " The ``Returns`` section supports any reStructuredText formatting,\n"
+ " including literal blocks::\n\n"
+ " {\n"
+ " 'param1': param1,\n"
+ " 'param2': param2\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}