$re = '/^(?: {4}|\t)(?P<name>\*{0,2}\w+):(?P<desc>(?:\s|.*)*)/m';
$str = ' bool: True if successful, False otherwise.
The return type is optional and may be specified at the beginning of
the ``Returns`` section followed by a colon.
The ``Returns`` section may span multiple lines and paragraphs.
Following lines should be indented to match the first line.
The ``Returns`` section supports any reStructuredText formatting,
including literal blocks::
{
\'param1\': param1,
\'param2\': param2
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);