const regex = new RegExp('^(?: {4}|\\t)(?P<name>\\*{0,2}\\w+):(?P<desc>(?:\\s|.*)*)', 'mg')
const str = ` bool: True if successful, False otherwise.
The return type is optional and may be specified at the beginning of
the \`\`Returns\`\` section followed by a colon.
The \`\`Returns\`\` section may span multiple lines and paragraphs.
Following lines should be indented to match the first line.
The \`\`Returns\`\` section supports any reStructuredText formatting,
including literal blocks::
{
'param1': param1,
'param2': param2
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}