$re = '~^@(\S+\.[^\s]+)$~m';
$str = '@php
@python
@stackoverflow.com
@google.com
@stackexchange.com
@perl
@regex
@google.com
@foo.com
@bar.com
@baz.com
@google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);