using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]+\s+[0-9]{6}\s+[0-9]\b";
string input = @"YOUU 410831 0 MEIU 810851 0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}