const regex = /[A-Z]+\s+[0-9]{6}\s+[0-9]\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]+\\s+[0-9]{6}\\s+[0-9]\\b', 'g')
const str = `YOUU 410831 0 MEIU 810851 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}