$re = '/[A-Z]+\s+[0-9]{6}\s+[0-9]\b/';
$str = 'YOUU 410831 0 MEIU 810851 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);