using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"text";
string input = @"TEXT text mytext lotsotexts texttexttext so much text!
The text can even be found on the second text-line.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}